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Scheduling the Upgrade
Although this guide identifies the typical upgrade steps required, we recommend that the 

OneStream Software Technical Support Team performs your upgrade. Contact them at 

support@onestreamsoftware.com.
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Requirements
Information Technology professionals responsible for installing, maintaining and supporting 

OneStream, must satisfy the following requirements to best support an upgrade. They must 

also review the requirements and special notes in the  Installation and Configuration Guide and 

Release Notes.

 l If upgrading from  OneStream 5.3.x or earlier, upgrade to 4.8 of the Microsoft .NET 

Framework for the latest security standards and  advanced features.

 l If updating from OneStream 6.4 or earlier, update the database schema. We 

recommend full database backups.

 l If you have 4.7, upgrade to version 4.8 of the Microsoft .NET Framework. You can install 

this component during a standard Microsoft Windows update.

 l In each application, complete the Compile all Business Rules and Formulas check 

to ensure that business rules use the proper syntax.

Internet Explorer End-of-Use
As of July 2022, if you have an Internet Explorer ClickOnce shortcut to the OneStream 

Desktop Client application, it will not launch the application of any version when IE is disabled 

inside of your organization. Starting with 7.0, newly created shortcuts will be created using 

PresentationHost.exe, which is a component provided by the .NET Framework. Upgrading to 

7.0 will not automatically update existing shortcuts. You need to manually create new ones or 

edit existing ones. To update an existing shortcut of any OneStream platform version, follow 

these steps:
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 1. Right-click on the existing desktop shortcut and go to Properties.

 2. Copy and paste the text in the Target field into the notepad.

 3. Replace this section “C:\Program Files\Internet Explorer\iexplore.exe”  with 

C:\Windows\System32\PresentationHost.exe-launchApplication (note that the “ “ are 

removed). 

 4. Copy and paste the whole text into the target field inside the shortcut's properties, click 

Apply, then click OK.

You will not be able to view embedded external web pages inside of OneStream when IE is 

disabled inside of your organization. Starting with 7.0, the external web pages will be 

embedded using the Microsoft Edge WebView2 runtime control. Microsoft is automatically 

installing the WebView2 runtime on Windows 10 machines. You can verify if the component is 

installed on your machine through Add or Remove Programs. It can also be downloaded 

directly from Microsoft.

Once IE is disabled within your organization, embedded web pages will no longer render 

inside of OneStream on versions 6.8 and older even if you have WebView2 installed. If your 

application uses features that embed external web pages, usually through properties that 

allow pointing to a URL, an upgrade to 7.0+ will be required with the WebView2 runtime 

control. Key OneStream features that allow embedding external web pages:

 l Dashboard component Web Content

 l Dashboard component File Viewer
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 l Dashboard component Button

 l A drill back Business Rule in Transformation Rules Connector
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Before Upgrading
Perform these tasks before upgrading:

 1. Perform a full backup of all OneStream databases.

 2. Download the OneStream installation package from the MarketPlace:

 a. Log in to the MarketPlace and select Software Download to get the latest version 

of OneStream.

 b. Download the Full Package or Server Software to get the appropriate setup files 

for the server installation.

 3. Verify the location of the OneStream configuration files:

 a. On each OneStream server, select Start > Programs > OneStream Software > 

Server Configuration Utility.

 b. Right-click the utility and select Run as Administrator.

 c. Select File > Open ASP.NET Configuration File and browse to the appropriate 

location.

 l On web servers: C:\Program Files\OneStream Software\OneStream

WebRoot\OneStreamWeb and select web.config.

 l On application servers:C:\Program Files\OneStreamSoftware\

OneStreamAppRoot\OneStreamApp
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The file opens and displays the path to the XFAppServerConfig.xml and 

XFWebServerConfig.xml configuration files.

 4. For a backup, copy these configuration files.

 5. Copy and paste the path to the configuration file. You will specify this location during the 

upgrade.

 6. Close the file without saving and exit the utility.

 7. Verify the OneStream service account in Internet Information Services Manager:

 a. The service account must be an Admin ID or in the IIS_IUSRS Group, 

Performance Log User and Performance Monitor Users group. The ID is required 

for queuing and CPU monitoring.

 b. On each OneStream server, select Start > Control Panel > Administrative 

Tools > Internet Information Services (IIS) Manage.

 c. Expand the server and select Application Pools. This displays application pools 

to the right. The OneStreamAppAppPool and OneStreamWebAppPool service 

accounts display in the Identity column. Note the Windows account and password 

as you will enter them in IIS after the upgrade.

 8. Verify the availability of the OneStream Application Server where:

 l The OneStream Database Configuration Utility is installed: On each OneStream 

application server, click Start > Programs> OneStream Software and verify that 

the OneStream Database Configuration Utility is installed. 
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 l The OneStream Studio is installed: On each OneStream application server, 

Start > Programs> OneStream Software to verify the OneStream Studio is 

installed.  You will re-install the Studio during the upgrade.
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Upgrading System Components
Perform the tasks in the following sections - in order, to upgrade the complete OneStream 

system. 

Stop the OneStream Application Pools
 1. On each OneStream server, launch Internet Information Services Manager by selecting 

Start > Control Panel > Administrative Tools > Internet Information Services (IIS) 

Manager.

 2. Expand the server and select Application Pools. This displays all pools to the right.

 3. Right-click these pools and select Stop:

 l OneStreamAppAppPool

 l OneStreamWebAppPool

 l OneStreamMgmtAppPool

 l OneStreamMobileAppPool

 4. Repeat these steps for each server in the environment.

 5. Close any open OneStream Configuration Utilities.
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Uninstall OneStream Servers
 1. Select Control Panel > Programs and Features > Uninstall a Program and locate 

the OneStream Servers component.

 2. Right-click OneStream Servers and select Uninstall.

 3. If it is installed, right-click OneStream Studio  and select Uninstall.

Re-Install OneStream Servers on an 
Application Server
This is the primary installation package that performs a complete server setup, including the 

web server, application server and all utilities. You can perform a custom install to choose the 

appropriate server components.

 1. Browse to the OneStream Servers package, right-click Setup.msi and select Install to 

run the server installation.

 2. Click Next on the landing page and accept the License Agreement.

 3. Specify the directory where the software was previously installed and click Next.

 4. Select Custom and click Next.

 5. On Select Features, choose Application Server and Server Configuration Utility  

and click Next.
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NOTE: You can choose the Database Configuration Utility if the application 

server is the server where the Database Configuration Utility was previously 

installed.

 6. Click Install then Finish.

 Re-Install OneStream Servers on a Web 
Server

 1. Browse to the OneStream Servers package, right-click Setup.msi and select Install.

 2. Click Next and accept the License Agreement.

 3. Specify the directory where the software was previously installed and click Next.

 4. Select Custom and click Next.

 5. On Select Features, choose Web Server and Server Configuration Utility and click 

Next.

 6. Click Install then Finish.

 Re-Install OneStream Studio
 1. Browse to the OneStream Studio package, right-click Setup.exe and select Run as 

Administrator.

 2. Click Next and accept the License Agreement.

 3. Select Custom and click Next.
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 4. Select the directory where the software was previously installed and click Next.

 5. On Select Features, select all options and click Next.

 6. Click Install then Finish.

Upgrade the Framework and Application 
Databases
Before performing these steps, have a database administrator back up all OneStream 

databases.

 1. On the OneStream application server with the OneStream Database Configuration 

Utility installed, select Start > Programs > OneStream Software > OneStream 

Database Configuration Utility.

 2. Right-click the utility and select Run as Administrator.

 3. Right-click OneStream Framework Database and choose Upgrade Database 

Version.

NOTE: If this is disabled, an upgrade is not required.

 4. Confirm the upgrade.

 5. Repeat these steps for the application databases as necessary.
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 Update the ASP.NET Configuration File 
 1. On each OneStream server, launch the OneStream Server Configuration Utility by 

clicking Start > Programs > OneStream Software > Server Configuration Utility.

 2. Right-click the utility and select Run as Administrator.

 3. Choose File > Open ASP.NET Configuration File and browse to the appropriate 

location:

 l Application server: C:\Program Files\OneStream Software\OneStreamAppRoot\

OneStreamApp

 l Web servers: 

 o C:\Program Files\OneStream Software\OneStreamWebRoot\OneStreamWeb

 o C:\Program Files\OneStream Software\OneStreamWebApiRoot\

OneStreamWebApi

 l Mobile:C:\Program Files\OneStream Software\OneStreamMVCRoot

 4. Select the web.config file.

 5. When the file opens, copy the directory path of the configuration files.

 6. Save and close the file.

 7. Repeat these steps on each server in the environment.
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 Update the  Configuration Files
 1. Open the Application Server Configuration file and select File > Save.

 2. Close and re-open the same file.

 3. In Database Server Connections, select the ellipsis and update the command time-

outs for the OneStream Database Server connection:

Short = 90    *must do

Large =900 (minimum or 900)

 4. Select File > Save and close the file.

 5. Open the Web Server Configuration file.

 6. Select File > Save and close the file.

 Update and Configure IIS
 1. On each OneStream server, open the OneStream Server Configuration Utility by 

clicking Start > Programs > OneStream Software > Server Configuration Utility.

 2. Right-click the utility and select Run as Administrator.

 3. Choose Tools > Configure IIS.

 4. In Configure IIS, specify the following:
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 a. For Web Site Name, enter the name of the OneStream IIS Website to update.

 b. The OneStream App Server, Web Server and Mobile Server sites.

 5. Select Update IIS Default Settings.

 6. Select options to update IIS for the appropriate websites:

 a. Use Web Server Settings: Specify the  Mobile Web Server site.

 b. Use Web Server Settings: Specify the Web Server site.

 c. Use App Server Settings: Specify the App Server site.

 d. User Account Type: Specify Custom Account, then enter the user name and 

password of the OneStream Service account.

 7. Click Update IIS Settings then OK.

 8. Repeat these steps to set the appropriate IIS settings for the application pools in IIS.

 9. Click Reset IIS.

Test the  Login
 1. Navigate to the OneStream Windows App URL: 

http://<webserver>:50001/OneStreamWeb/OneStreamWindowsApp.asp

 2. Click Run to launch the Click Once Windows app.

 3. Confirm that you can log in.
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 4. From Application, select System Administration then click Connect.

 5. Select System > Tools > Environment to identify the application servers and their 

status.

 6. Verify that each server is active.

 Verify the Application
 1. Compile all business rules, being sure to:

 l Right-click the grid and export any errors for analysis using an Excel file format.

 l Apply updates as needed.

 2. Download Standard Reports from the MarketPlace and import the reports.
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Resolving Business Rule Compiler 
Errors
See:

 l "Compiler Update - Related Errors" below.

 l "Unsupported NameSpace - Related Errors" on the next page.

Compiler Update - Related Errors
Platform releases may include updates and enhancements to the Business Rules compiler, 

usually to improve syntax detection. Administrators must resolve these errors to fully compile 

business rules. Warning messages identify line items that will function but that you should 

update to support the latest compiler’s requirements. How to resolve these warnings varies. 

You may be able to use a provided replacement function or change to a function’s properties.

For example, the message below indicates a LookupRowFieldValue function property 

changed. Review the current rule and function definition to determine that the property for 

“Criteria as a String” changed. It now defines the field as a dbWhere object.

These were the old properties:
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LookupRowFieldValue(ByVal si As SessionInfo, ByVal dbLocation As String, ByVal 
tableName 
 As String, ByVal criteriaExpression As String, ByVal fieldToReturn As String, ByVal 
 defaultValue As String) As String

To resolve the condition, make the required change. In this example, use a dbWhere object to 

define the criteria against the target database table.

These are the new properties as shown below:

LookupRowFieldValue(ByVal si As SessionInfo, ByVal dbLocation As String, ByVal 
tableName
 As String,ByVal dbWheres As List(Of DbWhere), ByVal fieldToReturn As String, ByVal 
 defaultValue As String) As String

Unsupported NameSpace - Related Errors
OneStream uses Vb.Net language to help you implement custom solutions using predefined 

libraries and other compatible third-party libraries. When business rules compile, these default 

NameSpaces also compile:

 l microsoft.visualbasic

 l system.linq

 l system.collections.generic
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 l system.collections

 l system.text

CAUTION: If you use them, do not remove provided NameSpaces them from 

business rules. Removing NameSpaces causes compile errors.

These predefined NameSpaces are provided with business rules:

 l Imports System

 l Imports System.Data

 l Imports System.Data.Common

 l Imports System.IO

 l Imports System.Collections.Generic

 l Imports System.Globalization

 l Imports System.Linq

 l Imports Microsoft.VisualBasic

 l Imports System.Windows.Forms

 l Imports OneStream.Shared.Common

 l Imports OneStream.Shared.Wcf

 l Imports OneStream.Shared.Engine
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 l Imports OneStream.Shared.Database

 l Imports OneStream.Stage.Engine

 l Imports OneStream.Stage.Database

 l Imports OneStream.Finance.Engine

 l Imports OneStream.Finance.Database

Resolving an unsupported NameSpace issue depends on where the NameSpace is used.

 l If used in a business rule file: Add the NameSpace to the Imports code so the business 

rule can compile. For example:

 l If used in a member formula: Add the full NameSpace to the affected expression or 

variable, since you cannot modify Imports code. For example:
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